Composerのススメ(1)

By | 2013年7月18日

yukiです。

もう全てのライブラリはComposer経由でプロジェクトローカルに入れてしまえ!と思ってる今日この頃です。

自分の精神衛生上のためにも普及してほしいので、Composerの使い方をいくつか書きたいと思います。
Composerのインストール方法は*nix/Windowsの方法が公式ドキュメントで解説されてますので、そちらを参照してください。

依存ライブラリの指定

依存するライブラリはrequireで指定します。
パッケージ名はpackagist.orgから探します。

開発のために必要なライブラリはrequire-devで指定します。

composer install/updateの時に–no-devを付けると、require-devで指定されている依存はインストールされません。

 

バージョン指定の書き方

各依存ライブラリは依存するバージョンを指定します。
指定の仕方は次のようなものがあります。

  • 1.2.*: 1.2.0以上、1.3.0未満
  • >=1.2.3: 1.2.3以上
  • >1.2.3: 1.2.3より上
  • <=1.2.3: 1.2.3以下
  • <1.2.3: 1.2.3未満
  • ~1.2.3: 1.2.3以上、1.3.0未満
  • ~1.2:  1.2以上、1.3未満
  • 1.2.3@{stability}: 1.2.3で{stability}なものをインストール

マニュアル

 

最低限のstabilityの指定

stableやbetaやalphaなどの最低限必要とするstabilityがminimum-stability設定できます。
デフォルトではstableです。

stabilityに指定できる文字列は次の通りです。

  • dev
  • alpha{N} e.g.) alpha, alpha1
  • beta{N} e.g.) beta, beta1
  • RC{N} e.g.) RC, RC1

マニュアル

 

インストール場所の指定

依存ライブラリをインストールする場所はvendor-dirで指定します。
デフォルトではvendorにインストールされます。

 

オートローダーを読み込む

設定を終えてcomposer install/updateをすると、vendor-dirで指定したディレクトリにautoload.phpというファイルが生成されています。
これはComposerで管理されるライブラリ用のオートローダーで、読み込むことでrequireすることなしにライブラリを参照することができるようになります。

 

ここまででpackagist.orgに登録されているものは利用できるようになりました。
次回はプロジェクト固有のものやpackagist.org以外にあるライブラリを利用できるようにしてみたいと思います。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です